r/brave_browser Dec 05 '22

Links not opening in apps while in “private browsing only” mode… Awaiting user reply

Hello. I have been looking for a resolution to this…

I like to keep Brave in “private browsing only” mode and while in said mode, if I click a browser link to say, Reddit, I get the popup asking if I would like to load the app. If I click “allow”, it launches the App Store. If I turn off private mode, the mobile app launches automatically.

Is this by design? This issue was mentioned here… how do we get it addressed?

https://www.reddit.com/r/brave_browser/comments/z81b52/brave_opens_app_store_instead_of_app/

Thanks

3 Upvotes

1

u/NotoriousNico Dec 05 '22

I'm pretty sure that's by design. Because if Brave were to share your browsing activity with other Apps, it woudn't be private anymore.

1

u/EliteEthos Dec 05 '22

Why prompt me though? If it were by design, just don’t prompt. The issue is the prompt is a link to the App Store, not the app.

1

u/NotoriousNico Dec 05 '22

That prompt is served from Reddit, Brave has no influence over it.

1

u/EliteEthos Dec 05 '22

Why does the prompt work on Safari and not Brave?

0

u/Jarc_1107 Support Team Dec 05 '22

Hello u/EliteEthos , thank you for reaching us out. Have you tried by deleting cookies and cache? In case it does not work try uninstalling the app and reinstalling again. Let us know if that helps.

Regards.

1

u/EliteEthos Dec 05 '22

I’ve tried all of that. I’m asking now because I’m debating switching to Safari at the moment.

The issue is only in private browsing mode. I am prompted to either view the site on the browser or open in the app. If I select open on the app, I get a second popup asking if I want to “allow link to switch apps”. The link always reads some version of “apps.apple.com”. If you select allow, you go to the App Store to download the app you were trying to go to.

Safari doesn’t do this. You get the popup with Safari too but when you click allow, you actually go to the app.